Posting Bug in Xenforo when using an Android device

Welcome to Wondercafe2!

A community where we discuss, share, and have some fun together. Join today and become a part of it!

Mendalla

Eastern Lowland Gorilla
Joined
May 2, 2014
Messages
32,723
Location
The Forest City
I have just discovered via Xenforo's own forums that the predictive typing problems I have been experiencing on my Samsung are actually an issue with the rich text editor in Xenforo. While I use GBoard, apparently Swiftkey (another popular Android keyboard) is also affected. I have not tested with the native Samsung keyboard yet because, frankly, GBoard is so much better in other applications.

Basically, sometimes I have to select the correct autocorrect option multiple times to get it to properly overwrite the incorrect option. It often mangles things terribly rather than just putting the correct word over the incorrect one.

I have not heard reports of this from other Android users here, but thought I'd put it out there just in case.

Solution, apparently, is to turn off the rich text editor (I'll put instructions in a follow-up post). This will remove the ability to do things like bolding, highlighting, bullets, smileys (you can still do keyboard smileys like : ) though), etc. but if you don't use those much, it shouldn't be a problem.

Users who solely post from desktop systems and Apple devices should be okay. This only seems to be an issue using Android.
 
Last edited:

Mendalla

Eastern Lowland Gorilla
Joined
May 2, 2014
Messages
32,723
Location
The Forest City
To turn off the rich text editor, just click the wrench icon in the top right corner of the editor window (circled in the illustration below). To turn it back on, use the "Use Rich Text Editor" link that appears below the editing box.

Xenforo Editor.PNG
 

revsdd

Well-Known Member
Joined
Jun 6, 2014
Messages
5,516
Location
Beaverton, Ontario
I haven't noticed the problem, although I tend to read on my Samsung more than I post from it. But when I have posted I haven't noticed any significant problems.
 

Mendalla

Eastern Lowland Gorilla
Joined
May 2, 2014
Messages
32,723
Location
The Forest City
What keyboard do you use, @revsdd? Just the default that came on the phone? I wonder if the Samsung keyboard isn't affected. Haven't tried (I generally dislike manufacturer's keyboards) but maybe I will.
 

Jae

Well-Known Member
Joined
Jun 6, 2014
Messages
31,982
Location
Suwon, South Korea
Android here too. I haven't experienced any problem in posting things.

Well... at least on the techical side of things. :(
 

Luce NDs

Well-Known Member
Joined
Jan 4, 2015
Messages
47,710
Very dark enigmas ... problems that are unacknowledged ... part of the subliminal psyche ...
 

Mendalla

Eastern Lowland Gorilla
Joined
May 2, 2014
Messages
32,723
Location
The Forest City
I am unstickying this. It seems to be fixed in 2.1 based on my testing in dev and it's easy enough to avoid by switching keyboard.
 
Top